Use Microsoft Bookings to Schedule Faculty Office Hours

Issue:

I need an easy way to allow students to sign up for office hours. 

Environment:

Outlook

Microsoft Bookings

Cause:  

Multiple groups use multiple calendar apps. I need one that all can use easily.

Resolution:

Microsoft Bookings (available through Office365) is an application that was designed for small service providers (physical therapists, pet groomers, counselors, etc.) to allow their customers to view available time slots and perform their own bookings. What TLT Instructional Technologist, Mendi Benigni discovered is that it also works great to book office hours.

In addition to the example steps below, you can also follow the documentation provided by Microsoft Support and view the course, Microsoft Bookings Essential Training in CougarED (Catalog>Software Applications>Office).


Bucky Wall's Office Hours

I'm using myself as an example of a fictional professor who has office hours Monday, Wednesday and Friday from 1:00-4:00. You can follow these steps to set up your own Bookings site and allow students to self-schedule based on open slots.

1. Navigate to portal.office.com and select the Bookings Icon 

2. At the Booking home page, select New from the pull-down in the top left corner.

3. Enter the "Business name" and click Continue.


Business Information

4. Now work your way up the left nav-bar starting with Business Information.

  • Fill in the Business name, Business Address, and Business phone and email fields
  • Under Business hours, use the "+" and "x" buttons and pull-down options to set your hours:
    • + = Adds a block of time on the day
    • x = Removes a block of time
    • Pull-dows allow you to set the time.

5. Click Save and select Services.


Services

6. Select Services from the left-nav bar and you will see I have three services listed. When you log in the forst time you will only see one, which is called "Initial Consult." Click on it and it will open the Services page. This is the meat of the Bookings app, so I'll go through these by section. I'll demonstrate setting up a 1 Hour Appointment, but you can follow the same process for other appointment times. 

Bookings link, Staff, Service name, Description, Default location and Staff.
  • Select the Share via Email to share via email (Outlook OWA) or Copy the to paste in an email or document (Mendi has it in her email signature!)
  • Staff is you. You shouldn't need to add any more staff unless you want someone to assist you. We'll go over staff settings later.
  • Service name is your appointment.
  • Description is up to you. 
  • Default location is your office (or wherever you want to have the meeting). Can also be a Zoom or Teams link, in which case you can select the Add online meeting slider.

Default distribution, Buffer between meetings, Maximum number of attendees and Notes

  • Default duration. This is where you set the length of you office hours. Mine is set to one hour.
  • Buffer time. This is a great feature! This is the minutes between meetings that can't be booked. Mine is set for 15 minutes after each meeting. Note: if you set it before the meeting, then a person can't book an appointment at the beginning of your "Business Hours."
  • Since these are 1:1 meetings, keep the Maximum number of attendees to 1.
  • Notes are only to your self.

Custom Fields, Reminders and Confirmations, Publishing options

  • Under Custom Fields:
    •  Selecting Modify opens up a dialog box which allows to you choose what information is required at the time of the booking and add any addition questions or requirements. 
    • Reminders and Confirmations, allows you to either keep the standard email reminder which is sent to the student a day prior to the appointment, or by selecting Add an email reminder, you can customize a reminder message.
    • Additional Information for Email Confirmation allows you to add more information contained in the confirmation email at the time of the booking.
    • You can also send a text message reminder.
    • Leave the Publishing Options checked to allow people to book this appointment time. Unchecking it removes this booking option.

 

Online Scheduling Options, Scheduling Policy, Email notification, Staff and Availability

  • Leave the default scheduling policy unckecked.
  • Under Scheduling policy, I've selected the Time increments in 30 minute increments. 
  • I have left the Minimum and Maximum lead times at the default setting.
  • Under Email notification, I've selected both the "Business" (Me) and to send a confirmation email to the student and an Outlook meeting request.
  • Leave Staff unckecked as you are the only "Staff".
  • Select Bookable when staff are free as the system will look to your Booking Calendar to make sure you are not double-booked.


Staff

Select Staff on the left-nav bar and then your name to open up the Staff page for you. As you are the only "staff", there are only a few things to do here:

  • Make sure the email address under you name is correct.
  • Under, Email notification, the box is checked.
  • Under, Availability, both Events on Office Calendar affect availability and Use Business hours are checked.


Customers

You don't need to do anything now here. This will populate as you have bookings.


Calendar

Before we go to the Bookings Page, let's take a look at the Calendar. All of your booking will show up here and any conflicts will keep students from booking over other appointments. You can even manually create a booking under New booking. Also, you can block Time off to avoid booking when you might be unavailable. Note: Be sure to select yourself, even though you are the only "staff".


Booking Page

In some ways this is a summary of what we have done so far. This is what the students will actually see when they book an appointment with you. You will see that it looks like some of the decisions you made in Services didn't populate here. That's because the Bookings Page is you global presence and can include several services. To keep it simple, though, just add in the same settings as you did before. However, there are some unique functions:

  • Booking page status displays your URL and allows you to either copy or share it through Facebook (with the ability to add the "Book Now" button Facebook page), Twitter or Email.
  • Under Scheduling Policy and Email notofocations, make sure your Time increments and notifications are as you set them in Services.
  • Leave the Staff box unckecked.
  • Under Customize you page, you do have the ability to choose colors and upload a logo or image to spruce up you Bookings page if you desire. 
  • You can change your Regional and time zone settings, or just check, Always show time slots in business time zones.


See your site!

Select Save and publish, then Open published page to look at your Bookings site.

My Bookings page! In this example, I've made a 1 Hour Appointment on 11 September at 1PM. I scrolled down to add the required fields and clicked Book. 

The student has the opportunity to make changes after the initial booking or by returning to the site.

 

My email notifications as the "student" (with meeting request) and the "faculty". 


 

 

Still need help? Email Bucky at wallrs@cofc.edu. 

 

 

 

 

Details

Article ID: 109523
Created
Tue 6/9/20 3:44 PM
Modified
Tue 7/12/22 3:00 PM