I can no longer use the Student ID search box in Degree Works

Issue:

When I try to use the Student ID search box in Degree Works, I get access denied 

Audience:

Advisors

Environment:

Degree Works

Cause: 

Your access has been removed. This is likely due to non-compliance with faculty advisor requirements. As of Summer 2021, all faculty members are required to have completed both the Privacy and FERPA modules in CougarEd within the last 12 months.  

Resolution:

  1. To complete one or both missing course modules, first log onto CougarEd at https://cofc.myabsorb.com/.
  2. Open the Course Catalog.
  3. Open the New Employee, Faculty, and Staff Compliance Training folder and view the status of these two courses:
    • 02. The College of Charleston's Privacy Policy: What you need to know!
    • 05. FERPA.
  4. Select Enroll (or Re-enroll).
  5. Complete the course. (Repeat steps to complete the other missing course if needed.)
  6. After you have completed the requirements, your name will appear on the weekly report for access to be re-established manually. At this time, access is not automated and may take up to a week. Please log onto DegreeWorks to check your access.

 

 

Do you still need help?  Email Degreeworks@cofc.edu

 

 

Details

Article ID: 136376
Created
Mon 8/2/21 3:07 PM
Modified
Mon 1/24/22 9:59 AM

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