Emails Going to Junk Folder After Blocking the Sender

Issue:

I blocked spam that was being delivered to my email, but I am still getting the emails. They are just going to my junk folder now.  Why am I still getting these emails?

 

Audience:

CofC faculty and staff

 

Environment:

Outlook

 

Cause:

As part of its filtering criteria, the Outlook Junk Email Filter checks message senders against lists of email addresses and Internet domains designated either as safe or to be blocked. You can customize the filter to block or allow senders or different message types.

 

Resolution:

This is the expected behavior, and is the purpose of the Junk Email folder. 

The blocked person can still send you mail, but if anything from his or her email address makes it to your email account, it’s immediately moved to the Junk Email folder. Future messages from this sender will go to your Junk Email folder.

 

If your email address is subscribed to a service and you no longer want to receive the subscription, look for an unsubscribe link at the bottom of the email to remove your address from their subscription list.

See Manage Spam Emails for more information.

 

Do you still need help?  Create a support ticket and a Service Desk technician will contact you. 

 

 

 

Details

Article ID: 137439
Created
Wed 9/1/21 1:55 PM
Modified
Thu 3/10/22 2:40 PM

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This article gives an explanation of the Junk Email Filter in Outlook so you can manage spam messages.