Issue:
How do I request a transcript?
The site never loads when I click the link in MyCharleston to request a transcript.
Environment:
MyPortal
Parchment
Cause:
There are several causes that would prevent a student from requesting a transcript. The most common are:
-
Lack of credentials
-
Incompatible browser
-
Pop up blockers
-
Slow network speed
-
Firewalls
Resolution:
The Official Academic transcript will show the same information as the Unofficial Academic Transcript. The Unofficial Academic transcript will not have the signature from the Office of the Registrar, but it does show the same courses/grades.
If requesting an official transcript at the end of your final semester, there is an option to hold for final grades to ensure that the transcript is not sent until the last semester's grades are finalized.
Current students can use the Parchment ordering service available through MyPortal.
- Make sure your browser is not blocking pop-ups.
- Log into MyPortal
- Click on the Transcripts Tile
- Click Order Official Transcript; this will open the Parchment site in a new window.
Alumni or former students who do not have a current MyPortal account may order directly with Parchment at www.parchment.com
For additional help please view How to Order a Transcript with Parchment video or see the FAQ’s.
Students who may not have access to a major credit card or the Internet should contact the Registrar’s Office transcript team mycofctranscript@cofc.edu to discuss options.
COURSEWORK PRIOR TO 1990
You may use the Parchment online ordering system. Because many academic records prior to 1990 are preserved on microfilm, additional processing time may be required.
Do you still need help? Contact Registrar's Office Transcript team at mycofctranscript@cofc.edu