Find My Permanent Credentials

Issue:

I never received an email with my permanent MyCharleston credentials.

I never received my Cmail account.

 

Environment:

MyCharleston or Cmail

Newly admitted students

 

Cause:

New students must have permanent login credentials in order to access resources such as the Housing Application fee, Parking, Cmail, Appointment Manager, Add/Drop Classes, etc.

Reasons why a new student has not received an email yet with the new credentials include:

  • All required deposits have not been made yet.
  • The email has not been sent yet. Allow 48 hours for processing after deposits are made.
  • The email is in the junk/spam folder or sent to a different account than expected.

Resolution:

  1. If permanent credentials have been created, you can look up the login online.
  2. If all deposits have not been paid, make the required deposits through eBill: Tuition Deposit, Housing Deposit, Housing Application Fee
    • Fill out a waiver for the Housing Application Fee and Housing Deposit if you will not be living on campus
  3. If you have paid the deposits within the last 2 business days, allow time for the Treasurer's Office to process the payment.
    • Treasurer's Office: 843-953-5572
  4. If the Treasurer's Office confirms all required deposits have been made, and it has been at least 2 business since the payments were processed, submit a ticket for IT. The Identity Access Management group will review your ticket to resolve the issue. 

Do you still need help?  Create a support ticket and someone will contact you.  MyCharleston Access

Details

Article ID: 32703
Created
Thu 6/29/17 10:50 AM
Modified
Tue 8/4/20 8:56 AM