Issue:
I never received an email with my permanent MyCharleston credentials.
I never received my Cmail account.
Environment:
MyCharleston or Cmail
Newly admitted students
Cause:
New students must have permanent login credentials in order to access resources such as the Housing Application fee, Parking, Cmail, Appointment Manager, Add/Drop Classes, etc.
Reasons why a new student has not received an email yet with the new credentials include:
- The $400 enrollment deposit has not been made yet
- The email has not been sent yet. Allow 24 hours for processing after deposits are made.
- The email is in the junk/spam folder or sent to a different account than expected.
Resolution:
- If permanent credentials have been created, you can look up the login online.
- If the enrollment deposit has not been paid, make the required deposit through eBill
- If you have paid the deposit within the last business day, allow time for the Treasurer's Office to process the payment.
- Treasurer's Office: 843-953-5572
- If the Treasurer's Office confirms all required deposits have been made, and it has been at least one business day since the payment was processed, submit a ticket for IT. The Identity Access Management group will review your ticket to resolve the issue.
Do you still need help? Create a support ticket and someone will contact you. MyCharleston Access