Issue:
Why can't I register for classes?
"You are not permitted to register at this time."
I have a hold on my account. How do I get it off?
Environment:
Applies to active students
Those who have been inactive will need to reapply before being able to register
Cause:
Potential reasons:
- Only students who are scheduled for orientation can register during orientation dates
- Past due payments
- Hold(s) on the account
- Prerequisites are not met
- Number of hours have not been met
- Student must acknowledge and sign the Student Financial Responsibility form.
Resolution:
- Check the Orientation schedule to verify orientation sessions are not occurring: http://orientation.cofc.edu/
- Verify Registration entry times: http://registrar.cofc.edu/calendars/entrytimes.php
- View your eBill to make sure you are caught up on payments.
- Verify required labs or prerequisites
- Verify that you do not have any holds on your account (as well as general Registration Status): MyPortal Registration Guide
- If you have been on a leave of absence, you will need to contact the Center for Academic Performance, 843-953-5674, to update the inactive leave status before you will be able to register.
- Other issues will need to be directed to the Registrar's Office for assistance (For example, honors students who cannot register may be caused by a pin number issue, which has to be fixed by the Registrar).
Do you still need help? Visit the Registrar's website http://registrar.cofc.edu, call 843-953-5668, or email registration@cofc.edu for specific questions regarding registration or holds.
Need help accessing MyCharleston? Call Service Desk at 843-953-3375, or start a chat session.