Can't Register for Classes

Issue:

Why can't I register for classes?

"You are not permitted to register at this time."

I have a hold on my account. How do I get it off?

 

Environment:

Applies to active students

Those who have been inactive will need to reapply before being able to register

 

Cause:

Potential reasons:

  • Only students who are scheduled for orientation can register during orientation dates
  • Past due payments
  • Hold(s) on the account
  • Prerequisites are not met
  • Number of hours have not been met
  • Student must acknowledge and sign the Student Financial Responsibility form.

 

Resolution:

  1. Check the Orientation schedule to verify orientation sessions are not occurring: http://orientation.cofc.edu/
  2. Verify Registration entry times: http://registrar.cofc.edu/calendars/entrytimes.php
  3. View your eBill to make sure you are caught up on payments.
  4. Verify required labs or prerequisites
  5. Verify that you do not have any holds on your account (as well as general Registration Status): MyPortal Registration Guide
  6. If you have been on a leave of absence, you will need to contact the Center for Academic Performance, 843-953-5674, to update the inactive leave status before you will be able to register.
  7. Other issues will need to be directed to the Registrar's Office for assistance (For example, honors students who cannot register may be caused by a pin number issue, which has to be fixed by the Registrar).

 

Do you still need help? Visit the Registrar's website http://registrar.cofc.edu, call 843-953-5668, or email registration@cofc.edu for specific questions regarding registration or holds.

Need help accessing MyCharleston? Call Service Desk at 843-953-3375, or start a chat session.

Details

Article ID: 33933
Created
Fri 7/21/17 10:18 AM
Modified
Wed 3/23/22 9:07 AM

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