Update Mailing Address

Issue

How do I update my mailing address in MyCharleston?

I get an error: "You cannot have overlapping dates."

 

Environment

MyCharleston

Students, alumni, and employees

 

Cause

You cannot have two addresses of the same "type" (ex: Home/Permanent, or CofC Office) with overlapping dates.

 

Resolution

Instead of inserting a new address type, edit the Current address.

  1. Log into MyCharleston
  2. Open the Banner Self Service folder (located on Academic Services, Alumni, or Employee tab)
  3. Navigate to Personal Information> Update addresses
  4. Click the "Current" link to edit the current address
  5. After changing the address, click the Submit button

 

*Prospective students do not have access to the Academic Services, Alumni, or Employee tabs and should contact the Office of Admissions for assistance at 843-953-5670 or MyCharlestonApplicant@cofc.edu.


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Details

Article ID: 34985
Created
Wed 8/9/17 1:48 PM
Modified
Tue 8/17/21 12:36 PM

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College Employees who have had their name changed will need to place a request using the self service portal for their name change to be reflected in their college email & login, or they may contact the IT Service Desk.
This article describes where employees and students can go to update personal information in MyCharleston.