Issue:
When searching email, it searches the whole account, not just the Inbox
Environment:
Outlook 2016
Cause:
The default search item in Outlook 2016 is "Current Mailbox"
Resolution:
To the right of the search box, there is an option to determine on what the search is being performed.
Click the drop down arrow next to "Current Mailbox" and change it to "Current Folder."
Additional Search Options can be found online at Microsoft's support site.
Do you still need assistance? Create a support ticket and someone will contact you. Email Assistance