Error: Not assigned a role for the application

Issue:

"Not assigned a role for the application"

Unable to log into Office 365.

Unable to log into OAKS.

 

Example of the error, please note the error can vary. See the attached screen shot for another example:

Sorry, but we’re having trouble with signing you in.
AADSTS50105: The signed in user 'username@g.cofc.edu' is not assigned to a role for the application '22dc16c3-e055-48ee-87a3-58a60e7a0606'(OAKS Online).

 

Audience:

Newly admitted students

 

Environment:

Microsoft Azure

 

Cause: 

The error means the user is neither in the 'eligible to enroll' nor 'enrolled: all'' groups.

 

Resolution:

Students

  1. If newly admitted, wait a day.
    • You should be able to access CSAS (scholarships) shortly after applying.
    • Depending on the system/application you are trying to access, you may need to wait till closer to your orientation date.
  2. If you are trying to access OAKS, are you registered for a course? You will not have access to OAKS until after you have registered for courses. You cannot register for courses until after you attend orientation. You can confirm that you are registered for a course by checking your schedule.
  3. If still not able to access the account after a day, submit a ticket for support and someone will contact you. Include the following information:
    1. Your full name on record
    2. Your CWID
    3. What system/application you are trying to access
    4. The error message you receive
    5. If you have been accepted into the college yet, and when

 

 

Notes for IT Service Desk

  • The 'eligible to enroll' nor 'enrolled: all'' groups are auto-loaded from Banner every morning.
  • Alumni have access to OAKS now- they need to be a member of the role_Alumni group in AD. You can confirm that this is the case by checking Azure- can escalate to IAM if they are missing. Please note, though, that although Alumni may be able to pull up and log into OAKS, they do not have access to open up the course pages for old classes unless as part of an Incomplete grade or specially requested by the course's academic department AND approved by Academic Affairs/Provost.
  • If they are indeed registered for a course for the current term, and it has been more than a day since they registered for the course, escalate to IT-EAM-IAM.

Details

Article ID: 85145
Created
Mon 8/19/19 3:26 PM
Modified
Tue 8/16/22 6:27 PM

Related Articles (2)

For Faculty and Staff that have the correct username and password
Instructions for how to get into OAKS to access course information