Unable to connect to Spotify due to a firewall issue

Issue:

Unable to connect to Spotify due to a firewall error.

Error: A firewall may be blocking Spotify. Please update your firewall to allow Spotify. Additionally, you could try changing the currently used proxy settings, (Error code 126)

Environment:

Spotify desktop app, Windows, MacOS

Cause:

Incorrect or outdated Country settings.  Corrupt installation.

Resolution:

If you are currently or have recently been out of the country, verify that the Country and payment settings are correct on your Spotify account.  Instructions on how to do this are available on Spotify's website.

If issues persist the Spotify app may need to be uninstalled and reinstalled:

On your Mac:

  1. Close Spotify
  2. Click Go > Library in the menu bar. (You may need to hold the Alt key if Library isn't visible.)
  3. Open Application Support
  4. Move the Spotify folder to the Trash
  5. Click Go > Applications in the menu bar.
  6. Move the Spotify application to the Trash
  7. Reinstall Spotify from their Downloads Page

On Windows:

  1. Close Spotify
  2. Open the Control Panel
  3. Click Programs and Features
  4. Select Spotify in the list and click uninstall
  5. Follow the instructions on the screen
  6. Download and install Spotify from their Downloads Page

 

Do you still need help?  Create a support ticket and someone will contact you. Computer - Repair and Service

Details

Article ID: 92330
Created
Fri 11/15/19 8:54 AM
Modified
Thu 7/1/21 8:04 AM