Lenovo Chromebook C330 connected to eduroam/cofc-guest/Ethernet, but no internet available

Issue

Users of Lenovo Chromebook C330 laptop computers are unable to access web pages on the College networks. Wireless authentication works correctly and the computer appears connected, but no access to the Internet is apparent. USB Ethernet adapted connections suffer the same symptom.

Environment:

Chromebook OS

Specific reported model:
Lenovo Chromebook C330

Cause

Network engineering believes that the "Search Domain" DHCP option delivered by campus infrastructure is not being handled correctly by ChromeOS on this specific model. DNS lookups are intermittently appended with the cougars.int search domain, causing resolution failure and subsequent failure of website loads. This cause needs to be confirmed with a live system, but packet captures seem to indicate this as a possible cause.

Resolution

None. This appears to be a bug with the system and needs to be resolved by Google or Lenovo. There are no workarounds available in ChromeOS nor on the College infrastructure. Owners should return their Chromebook and exchange for another model or should wait for a bug fix.

 

Details

Article ID: 98986
Created
Fri 2/21/20 2:58 PM
Modified
Thu 2/4/21 8:21 AM